Hello, Guest the thread was 29k called and contains 249 replays

last post from Matthias at the

Raumluft-Wächter (CO-2)

  • hier also mal wieder der Vorstellungs-Thread des "erweiterten" Raumluft-Wächters:

    das ursprüngliches Design und Idee sind von @knusis

    https://github.com/Doctor-B/CO2-Raumluftwaechter


    ..und Matthias hat mir dann eine THT-Version davon entwickelt und das ist draus geworden:


     


    inzwischen hab ich noch ein wenig an der Software gefeilt (bzw. ein befreundeter Furry hat mir eine komplett neue Software geschrieben, bei der auch ein Serieller Monitor zum Einsatz kommt)

    das Teil unterstützt aktuell RTC ( Real Time Clock) sowie Helligkeits-Sensor BH1750 und kann sich also in einen "Nacht"-Modus schalten, in dem dann nur noch 1 LED angezeigt wird (damit es nicht so hell im Schlafzimmer ist)


    zwar ist die Corona-Pandemie "fast" vorbei, ...aber ich finde, das Teil hat sich echt gut bewährt und verdient eine weitere Entwickung

    hier nochmal die Rückseite

  • Auch ein cooles Project :thumbup:


    Das werde ich auf jeden Fall auch noch nachbauen . Den teuren Sensor habe ich hier schon liegen , aber ich brauche erst mal ne Platine .


    Kommt Zeit kommt Platine ^^

    Eine ADMIN schläft nicht er ROOT

  • Hab ich auch schon im anderen Forum damals bewundert.


    Finde ich ne praktische Anwendung und so was habe ich früher mit dem Raspi mal ähnlich umgesetzt.

    Ist aber lange her und das Projekt habe ich wieder auseinander genommen. Fotos gibt´s leider nicht.

    Ich kann mich kaum noch dran erinnern, aber da wurden dann die gemessenen Daten in eine Datenbank geloggt und nach einer Woche wieder raus geschmissen, um die Menge an Daten klein zu halten. Man konnte sich das dann über Weboberfläche die Daten ansehen.


    War aber alles copy /paste und nichts wirklich selbst Entworfenes.


    War auch keine Platine. Nur Lochraster und fliegende Verdrahtung.


    Waren so die ersten Schritte von mir, auch mit Lötkolben.

  • :schild48:


    ich hab ja ne schicke Software für den Arduino Nano vorliegen, die auch soweit sehr gut funktioniert


    kennt sich einer von euch gut genug aus, um diese auf einen Teensy 3.5 zu portieren?

    dann würde ich gern mal die 2. Version, die Matthias mir damals erstellt hat aufbauen


    ...für den "Software-Spezialisten" gibts dann natürlich einen Satz Platinen und Kleinteile (also Widerstände, Kondensatoren, Bolzen, Schrauben etc. ) gratis

  • Auch ein cooles Project :thumbup:


    Das werde ich auf jeden Fall auch noch nachbauen . Den teuren Sensor habe ich hier schon liegen , aber ich brauche erst mal ne Platine .


    Kommt Zeit kommt Platine ^^

    So, die Platinen sind diese Woche gekommen .

    Danke an Andreas Shadow-aSc dafür .


    hier mal ein paar Bilder vom Aufbau





    Es fehlt noch das 74LS125 , ist aber schon unterwegs . und dann weiß ich noch nicht wohin mit dem BH1750 . Die Pins unter der Beschriftung sind alle mit GND verbunden . Aber das wird Andreas bestimmt noch aufklären .


    Außerdem kämpfe ich gerade mit der Programmierung des Arduinos , aber auch das wird noch klappen , ich habe da auch immer so meine Probleme :D


    Jetzt mache ich erst mal einen Moment Pause :sauforgie:

    Eine ADMIN schläft nicht er ROOT

  • zum Arduino Nano: als erstes musst du mal den Bootloader auf die "neue" Version updaten! ... ..der "old Bootloader" hat leider ettliche Bugs und so funktioniert z.B. das automatische Resetten nicht ...was aber extrem wichtig ist, weil der Sensor sich leider so ca. 4x pro Tag aufhängt :happy_045:

    ..und der Watchdog vom Nano merkt das und führt dann einen Reset aus :happy_2:


    den 74XX125 kannst du erstmal ignorieren, der ist nur für die SD-Karte zuständig und die ist .... noch nicht programmiert :whistling:

  • So, bin gerade etwas ratlos .


    Der Bootloader ist geflasht , das hat gut funktioniert .


    Die ino konnte ich dann auch , nachdem ich gefühlt hundert Bibliotheken installiert hatte fehlerfrei kompilieren und auf den Nano flashen .


    Wenn ich das Teil anschließe dann werden die LED's langsam Rot . Mehr passiert nicht .


    Das Display wird irgendwie nicht angesprochen .

    Ich habe mir die Datei //die Adresse des Displays wird in ~/Arduino/libraries/ssd1306/src/intf/i2c/ssd1306_i2c_conf.h Zeile 47 festgelegt.


    angeschaut , die Adresse die in Zeile 47 steht 0x3c soll auch top für mein Display verwendet werden . Habe also erst mal nichts geändert an der ssd1306_i2c_conf.h .


    Wenn ich das # vor dem define Befehl entferne kommen wilde Fehlermeldungen .


    Muss ich eigentlich in der ino. auch die # vor den include Befehlen entfernen ? Wenn ich das mache kommen auch viele Fehlermeldungen .


    Ich meine z.B. diese hier :


    C
    //die Adresse des Displays wird in ~/Arduino/libraries/ssd1306/src/intf/i2c/ssd1306_i2c_conf.h Zeile 47 festgelegt.
    #include "ssd1306.h"
    char str_temp[6];
    char buf[10];
    char clockbuf[]="                     ";
    
    #include "myFont.h"
    
    #include "LEDRing.h"
    LEDRing ledring;



    Dann habe ich noch das Problem wenn der Nano auf dem Board gesteckt ist , wird der Seriell Port nicht erkannt . Nehme ich den Nano vom Board runter wird er sofort erkannt und es wird auch im Terminal angezeigt das kein Airsensor installiert ist .


    Jetzt hole ich mir erst mal meinen zweiten Kaffee ... dann gehts weiter :whistling:


    Ich habe leider nur ne Menge gefährliches Halbwissen :saint: und versuche viel mit Try an Error . Ich glaube ich brauche mal nen richtigen Arduino Kurs ...

    Eine ADMIN schläft nicht er ROOT

  • AAAH - das hatte ich total vergessen zu erwähnen (wo ist der Facepaw-Smilie?)


    das SSD1309 kann ja sowohl als SPI als auch als I2C - Display verwendet werden.. das musst du natürlich erstmal umbauen!


    ..Anleitung folgt gleich

  • ..ist sogar hinten beschrieben, wie es gemacht wird, bloss nicht "sauber" formuliert:


    also - der R4 (4,7kOhm) vorsichtig auslöten ( ich mach das mit einer möglichst breiten Spitze, die beide Seiten des Widerstands gleichzeitig erreicht - dann mit dem Lötkolben von den Lötstellen mittels einer Pinzette runter heben und den Widerstand mit der Pinzette vom Lötkolben runter zupfen - beide Seiten sauber machen - und das Lötzinn von den Pads von R3 auch gleich absaugen)


    danch den Widerstand auf die Pads von R3 auflöten

    und für R5 einfach nur eine Brücke - oder nen fetten Lötzinn-Klecks einlöten


    Jetzt ist das Display auf I2C :thumbup: und hat die Adresse 0x3C 8)


    hinten neben der Display-Leiste ist aber auch noch ein Platz für einen ...ich glaub 10k Widerstand - wenn du den bestückt hast, dann ändert sich die Adresse auf 0x3D ...dann musst du diese "neue" Adresse entsprechend im Skript einstellen

  • den R4 hatte ich schon von auf R3 gelötet .


    Auf R5 hatte ich einen 4,7k eingelötet , jetzt eine Brücke .


    Ewas ist mit R7 ? bekommt der auch eine Brücke ? der ist bei mir noch unbelegt .


    Die Adresse habe ich jetzt auf 0x3D geändert, weil ich den 10k Widerstand eingelötet hatte bzw. habe .


    Nach wie vor meldet der über USB angeschlossene Nano sich nicht am PC an . Erst wenn ich ihn vom CO2 Board nehme kann ich ihn per USB ansprechen .



    Sehr merkwürdig ..


    Jetzt geh ich erst mal Tannenbaum kaufen :weihnachtsbaum04:

    Eine ADMIN schläft nicht er ROOT

  • Ewas ist mit R7 ?

    ..das ist sozusagen die "interne" Möglichkeit, die Adresse zu wechseln - auch hiermit könnte man zwischen 0x3C oder 0x3D umschalten


    der Einfachheit halber würde ich beide Widerstände weglassen (also deinen 10k wieder entlöten) , dann hat das Display wieder 0x3C und du brauchst nix am Skript bzw. an der Arduino-Bibliothek ändern ;)


    der kleine Jumper, der neben dem Display ist, legt die Reset-Leitung vom Display auf den Reset-Port vom Nano - der muss geschlossen werden, wenn das Display funktionieren soll - denn das grosse Display braucht zusätzlich noch nen Reset

    ..der muss aber offen sein, wenn man eine neue Software auf den Nano übertragen möchte, weil sonst das Display ständig den Reset auf +3,3V zieht


    ..dass der Nano aber gar nicht angesprochen werden kann (also auch nicht mit dem seriellen Monitor) hab ich allerdings noch nie erlebt :/

    ich hab aber auch selbst noch keine der "neuen" Platinen aufgebaut ...möglicherweise ist noch ein Fehler drin?

    ..ich werd am Montag mal selber eine aufbauen und probieren

  • Hallo,


    gibt es irgendwo einen Schaltplan ? dann klingel ich mal durch .


    Den DS3231 habe ich auf beiden Seiten verlötet.


    Nun werde ich mal den 10k wieder auslöten und schauen was passiert . aber ich glaube ja momentan an einen Fehler auf der Platine ..


    Ich gehe gleich noch mal suchen .


    Gruß Martín

    Eine ADMIN schläft nicht er ROOT

  • oh blöd, die Daten von der neuen Platine hab ich nur lokal auf dem PC in meinem Büro gespeichert :cursing:


    ...aber prinzipiell hab ich ja nicht viel geändert im Bezug zu dem ursprünglichem Projekt von @knusis - das findet man hier:

    https://github.com/Doctor-B/CO2-Raumluftwaechter

    ..da ist auch ein Schaltplan und eine virtuelle Bestückung mit dabei


    Jetzt geh ich erst mal Tannenbaum kaufen

    ...also bei mir dauerte so ein Vorgang immer minimum 1/2 Tag ;) ...und du schreibst bereits nach 30 Min. wieder was? ...wie hast du DAS denn so schnell hinbekommen? =O

  • Tannenbaumverkauf ist hier im Dorf, ca. 500 m entfernt ...hin , ein wenig mit meiner Frau Frau diskutieren :D Kaufen und wieder nach Hause ... dann weiter basteln :whistling:


    ja ich habe mir den Schaltplan von knusis schon mal zur Gemüte gezogen .


    Einen Fehler habe ich gefunden ... Beim 22µF habe ich beide Pole kurzgeschlossen.:wut_131: :wut_060:


    ( das habe ich von Shadow-aSc hier geklaut )


    Der Nano wird aber immer noch nicht an der Seriellen erkannt . Das kommt später ...



    Jetzt gehe ich erst mal den Tannenbaum aufstellen .


    Der Steht immer im Garten vor den Fenstern .. Dieses Jahr wird er draussen bleiben und gar nicht rein kommen :thumbup:


    Bis später ...

    Eine ADMIN schläft nicht er ROOT

  • So, ein bisschen läuft was . Der Co2 sensor läuft . Die Temperatur ist jenseits von gut und böse und die Luftfeuchtigkeit stimmt auch nicht .


    Das Programm zum Uhrzeit stellen muss ich noch finden .


    Die Serielle Übertragung läuft immer noch nicht .


    Da bin ich noch ratlos .


    Es wird weiter experimentiert :D


    So sieht es aus



    Gruß Martín

    Eine ADMIN schläft nicht er ROOT

  • na also, das sieht doch schon gut aus :thumbup:


    alle Werte lassen sich normalerweise über den Seriellen Monitor aus der ArduinoIDE heraus ändern .... wenn das aber bei dir nicht geht? :/

    die Baudrate hast du aber auf 115.200 eingestellt - ja?


    achja - und du musst natürlich ganz oben bei den Offset-Werten Zahlen mit Punkt eintragen - nicht mit Komma :!:


    auch die Uhrzeit und das Datum lassen sich über den Seriell-Monitor einstellen


    edit: was mich grad total verblüfft: ...dein CO2-Wächter läuft ja im Dunkel-Modus, weil die oberste Zeile im Display nicht invers dargestellt wird ..du hast also vermutlich den BH1750 noch nicht angeschlossen?

    (kleiner Tip am Rande - die Pins des Sensors passen übrigens exakt mit den Pins des SCD30 überein - du kannst also auch auf die Pinleiste vom SCD30 einen zusätzlichen Sockel drauf"pappen" und den BH1750 dort einstecken ;) )


    und TROTZdem sind die LEDs alle an und auch hell ... :/ kurios!

  • Hallo,


    Ja Baudrate war richtig eingestellt .

    Ich habe es jetzt auch hinbekommen , oder sagen wir mal so, ich habe was hinbekommen …


    So sieht’s jetzt aus :



    Ich habe es jetzt folgendermaßen hinbekommen :


    Arduino von der Platine runter nehmen und mit dem Mac verbinden .

    Schwups , wird die Schnittstelle erkannt und gemeckert das der Airsensor nicht da ist ( im Terminal Programm über die serielle Schnittstelle )


    Nun habe ich einfach mal unter Spannung den Arduino vorsichtig in den Sockel gesteckt .. Und siehe da …

    Das Menü erscheint und ich konnte alle Parameter so setzen wie es sein soll . Habe,einfach erst mal alle Offsets auf 0 gesetzt, die Zeit gestellt, Datum und die Lux Zahl auf 20 , damit funktioniert auch der NightModus .


    Ich musste nur herausbekommen wie es funktioniert . War aber echt einfach .


    Einfach die Zahl drücken z.b. 11 gefolgt von einem a für d(a)y und schwups war der Tag des Datums korrekt gestellt .


    seitdem läuft das Teil . Ich kann es auch vom strom trennen und wieder verbinden und es läuft , alle Werte da und zeigen korrekte Daten an .


    Nur die serielle Schnittstelle funktioniert immer noch nicht .

    Nach dem ziehen und wieder stecken des USB Steckers wird der nano wieder nicht vom Mac erkannt .

    Aber das kann man ja so machen wie ich oben beschrieben habe , ist ja auch Ok . Was da jetzt falsch läuft weiß ich nicht .


    Shadow-aSc : funktioniert bei Dir der serielle Monitor oder Terminal Programm nach erneuter Spannungszufuhr ohne den Trick den ich hier veranstaltet habe . Ich denke ja aber warum ist das so . Egal, erst mal läuft er jedenfalls und ich bin Happy . :hops_182:


    War also doch alles richtig angeschlossen …


    schönen Abend noch ..

    Eine ADMIN schläft nicht er ROOT

  • edit: was mich grad total verblüfft: ...dein CO2-Wächter läuft ja im Dunkel-Modus, weil die oberste Zeile im Display nicht invers dargestellt wird ..du hast also vermutlich den BH1750 noch nicht angeschlossen?

    (kleiner Tip am Rande - die Pins des Sensors passen übrigens exakt mit den Pins des SCD30 überein - du kannst also auch auf die Pinleiste vom SCD30 einen zusätzlichen Sockel drauf"pappen" und den BH1750 dort einstecken ;) )

    Der BH1750 war schon angeschlossen, hatte aber noch keinen offset wert . Es ist ständig zwischen Tag und Nachtmodus hin und her gewechselt .


    Ich habe ihn so befestigt :


    SCL mit nem Festen Draht verbunden und der Rest Flexibel . So schaut der Sensor wenigstens nach Oben , hatte ich mir so überlegt, falls ich noch mal ne Rückwand spendiere .


    Wie kann man den nun denn den SCD30 ordentlich kalibrieren ?


    G

    Eine ADMIN schläft nicht er ROOT

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!