Hello, Guest the thread was 2k called and contains 6 replays

last post from csdragon at the

Bootloader brennen für "User" verständlich?

  • Hi,

    ..ich mal wieder...


    bislang konnte ich immer problemlos mit meinem USBASP einfach an die ICSP (6pol.) anschliessen Bootloader direkt über die Arduino IDE brennen:


    das ging eigentlich immer völlig problemlos

    ..aber jetzt krieg ichs nicht mehr hin -


    aber ich hab ja auch noch einen Diamex-Programmer, um den Atmel vom RCT (Retro-Chip-Tester) auf die jeweils neue Firmware zu bringen (Slabbi schiesst ja praktisch im Wochentakt neue Software raus :whistling: )


    dafür hab ich ne schöne Erklärung gefunden:

    Quote

    die Anleitung ist schon etwas älter, aber hat mir gut geholfen. Mit der Arduino IDE 1.6.6 haben sich ein paar Änderungen ergeben:

    Die programmers.txt liegt im Installationsverzeichnis unter Arduino\hardware\arduino\avr

    Folgende Zeilen ergänzt:

    Diamex USB-ISP Programmer

    diamexavr.name=Diamex-AVR diamexavr.communication=serial diamexavr.protocol=stk500v2 diamexavr.program.protocol=stk500v2 diamexavr.program.tool=avrdude diamexavr.program.extra_params=-P{serial.port}

    Die serielle Kommoninikation wie in avrisp eingestellt, das Protokoll wie in avrispmkii. Damit kann ich Sketches Hochladen und auch Bootloader brennen.

    https://forum.arduino.cc/t/diamex-avr-usb-programmer/80421/9


    ..hat soweit auch alles super funktioniert, wird als Programmer direkt im Menü in der ArduinoIDE angezeigt - ...und bringt ebenfalls nen Fehler :cursing:


    was gibts denn noch für "einfache" Möglichkeiten einen neuen Bootloader auf meinen NanoV3 zu kriegen?

    ich hab, weil ich die Nanos von AZ-Delivery hab auch schon deren Methode probiert:

    https://www.az-delivery.de/blo…rduino-bootloader-brennen

    ... das klappt alles super - soweit, bis man den Button "Bootloader brennen" anklickt ...dann kommt n Fehler ;(


    achso - die Nanos funktionieren ansonsten gut - ich kann problemlos Sketche laden - aber halt immer mit


    ..und bitte keine Erklärung, wie mans mit Linux, Unix, Mac etc. oder über AvrDude machen kann .... das sind für mich alles böhmische Dörfer - da hab ich KEINE Ahnung von... ;(

  • ich hab auf dem Rechner hier noch nichtmal irgendeinen Slicer drauf - auch nicht Cura, den 3D-Drucker nutze ich immer von nem anderen PC aus


    im Geräte-Manager wird der USBasp als

    eingetragen - mit genau der gleichen Vendor-ID,


    die auch ArduinoIDE als Fehler meldet


    ...das ging aber bislang eigentlich immer :S


    ..einen Seriell-Port hab ich da noch nie angezeigt bekommen, da der Bootloader ja nicht über seriell, sondern über diesen USBasp übertragen wird dachte ich :/

  • So Jungs... nur ganz kurz:

    Nachdem wir unsere Server alle durchgecheckt haben nach dem Programm Log4j, welches ja gerade in den Nachrichten steht und sich eventuell zu der größten Sicherheitslücke aller Zeiten entwickeln könnte, habe ich unser Überprüfungstool (sorry, darf ich nicht raus geben) mal über meinen Windows-Computer laufen lassen...


    Die Sachen, bei denen ich es mir vorstellen hätte können, wie z.b. Cura waren nicht auffällig. Allerdings ist die Arduino IDE dabei aufgefallen... Diese nutzt das Log4j...

    Ich habe die bei mir jetzt erst Mal deinstalliert und warte auf den nächsten Patch...

  • und hier noch 2 Anschlussbilder, wenn es speziell um einen Nano geht (klappt aber auch bei den meisten anderen Boards, die ICSP - Schnittstelle haben:

    (aber die Nano haben bei Auslieferung ja meist diesen "Old Bootloader" drauf - da muss man eigentlich IMMER erstmal Bootloader updaten)




    P.S.: sinnvoll ist auch immer ein Kondensator (irgendwas ab 10µF bis 100µF) zwischen GND und Reset am Uno zu stecken

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!