Hello, Guest the thread was 1k called and contains 11 replays

last post from Shadow-aSc at the

C64 - Mouse 1351 - Adapter / Platine von Matthias

  • Hallo,


    nachdem ich gestern mit meinem Apple1-Nachbau ja sofort einen Erfolg verbuchen konnte, habe ich mich heute daran gemacht, eine der Platinen aus dem Bobbel-Fundus (made by Matthias) aufzubauen. Es war diese hier:


    Platine sah gut aus, auf den ersten Blick keine Fehler festzustellen. Also schnell die paar Widerstände, den Sockel und Taster und Buchse eingelötet, den ATMega8 geflashed und dann an meiner VC20-Workbench

    http://commodore.straessle.eu/2019/03/09/i-need-a-workbench/

    testen wollen.



    Glücklicherweise ist dort ein neues, selbstgebautes und kurzschlussfestes Netzteil angebracht. Denn nach dem Einschalten blieben alle Kontrolle-LEDs auf dem Board dunkel! Bitte was, was läuft den hier schief?


    Kontrolle der Lötstellen, alles OK. IC runter, nochmals getestet -> VC20 startet normal. Nun hatte ich bereits einen Verdacht und wollte das Schicksal nicht ein zweites Mal herausfordern: Ist die Betriebsspannung richtig am AVR angeschlossen? Also Nachmessen am VC20 OHNE IC, und siehe da -> verpolt !!! Das IC wird mit MINUS 5 Volt betrieben. Gut, das IC hat Schutzdioden integriert, und wie bereits erwähnt regelt das Netzteil für diesen Fall ab.


    Aber warum ist hier das verpolt? Ein Blick in den Schaltplan auf http://sensi.org/~svo/%5Bm%5Douse/ lässt erkennen, wo hier der Hase im Pfeffer liegt. Wenn man die D-Sub-Buchse laut Bestückungsplan einlötet (s. oberes Bild), dann ist ALLES spiegelverkehrt, d.h. der gesamte Joy-Port des Commodore ist falsch herum. Und weil die Betriebsspannung symmetrisch auf Pin 7 / 8 liegen, dreht sich die Betriebsspannung am IC. Schöner Mist!

    OK, wenn ich nun die Buchse auf der anderen Platinen-Seite einlöten würde, dann wäre ja alles wieder OK:



    Sieht lustig aus, aber dann kann ich es nicht mehr an die Control-Ports der Commodore stecken, dann stört die PS/2-Buchse. Auch Mist!


    Aufgeben gilt nicht, das Ding muss laufen. Also nochmals mit verschieden Buchsen und Ideen gespielt und TADAA, so herum eingelötet:



    Und nachdem ich noch die Fuses angepasst hatte (Standard-Werte sind 1MHz ohne Boot-Sektor, benötigt werden 8MHz MIT Bootsektor) hat dann alles geklappt und das Platinchen verrichtet nun tadellos seinen Dienst: :happy:


    Code
    avrdude -c usbasp -p atmega8 -U mouse+boot.hex
    avrdude -c usbasp -p atmega8 -U hfuse:w:0xDC:m
    avrdude -c usbasp -p atmega8 -U lfuse:w:0xE4:m

    Arris : Thomas, Du hattest auch eine solche Platine bekommen, also Vorsicht beim Aufbau !


    Nachschlag: C64-Netzteil !!!


    Nun bin ich gewarnt, denn ich habe mal heute parallel die C64-Netzteil-Platine angeschaut. Nun mit anderen Augen, und siehe da, die nächste Ungereimtheit:



    Die Brücken-Endstufe mit ihrem Penta-Watt-Gehäuse passt ÜBERHAUPT nicht zur Platine ! Falsches Rastermass, falsche Anzahl der Pins, und auch die Schaltung per se gibt mir noch mehr als Rätsel auf. Die hole ich mir mal später zur Brust, seid also hier GANZ vorsichtig, Bitte :tra_106:


    Bei Fragen gerne melden, ich helfe gerne ...



    Have fun ;)


    Chris cassy-de


    .

  • ich hab ja die USB-Maus-Platine mit dem AT-Mega ...aber in dem Rastermass, wie Matthias den hier geplant hat, gibt es das IC gar nicht zu bestellen... auch eher ungünstig :whistling:

    eigentlich schon .


    diesen hier z.b. https://www.ebay.de/itm/ATMega…6&mkrid=707-127634-2357-0

    Eine ADMIN schläft nicht er ROOT

  • nee - das is n DIP-Gehäuse - ich hab aber eine Maus-Platine von ihm, mit einem At-Mega im TQFP-Gehäuse ..allerdings mit so winzigem Pinning, dass da ein "normaler" SMD-Chip nicht drauf passt


    ich mach später mal ein Foto

  • ich bin ja noch das Foto schuldig:


    das ist eine der USB-1351 - Adapter-Platinchen, die ich mal von Matthias bekommen hab


    ..wie man unschwer sehen kann

    (wenn man mal den SD2IEC-Adapter vom Tuning-Board daneben hält)

    - da passt ein "normaler" TQFP gar nicht drauf... - und auch die ICSP-Buchse dürfte ....schwer zu finden sein :/ :thumbdown:

  • den Adapter kenn ich noch gar nicht .

    Muss ich mal schauen ob der bei mir noch irgendwo, unentdeckt , rumfliegt .


    Ich brauche aber auch am C64 eigentlich keine Maus ;)

    Eine ADMIN schläft nicht er ROOT

  • Ui - ich hab grade eben entdeckt ... der AtMega von einem USBASP passt perfekt!


    ..und da die Dinger ja praktisch NICHTS kosten

    ...da werd ich mir den mal runter"föhnen"


    aber der hat nur 12MHz?

    :schild48: passt das? - hat denn schonmal irgendjemand einen Mouse-Adapter von Matthias gebaut?

    ..für Geos wäre eine USB-Maus schon sehr praktisch :/

  • .für Geos wäre eine USB-Maus schon sehr praktisch

    ... allerdings befürchte ich, dass daraus leider nichts wird. Denn dieser Adapter arbeit "andersherum". Will heißen, dass man dort eine Original-1351-Maus anschließt und die dann einen USB-Stecker-Anschluss hat, also zur USB-Maus wird. Die kann man dann für einen Emulator wie z.B. VICE super benutzen.

    Anders herum geht leider nicht, weil ...

    Denn IMHO wird es nicht möglich sein, dem ATMega8 ohne Zusatzhardware einen USB-Host-Modus einzuverleiben, denn er hat kein natives USB-Interface, noch ist dazu in der Lage, dies in Software nachzubilden (zu langsam, zu wenig Speicher ...). So etwas in der Richtung habe ich ja mit meinem PS4-C64-Adapter nachgebaut, und der ATMega2560 braucht auch schon Hardware-Unterstützung dafür.


    https://github.com/cassy-de/PS4-C64-blue-thunder



    Was geht, das hat man ja mit dem USBASP gemacht, ist der USB-Device-Mode, wenn auch nur als USB1.1, aber egal, Hauptsache funzzt. Und das entsprechend umprogrammiert und als USB-HID angemeldet.


    Have fun ;)


    Chris cassy-de


    .

  • ARGL ....

    na gut, DAS bringt mir dann tatsächlich nichts - mit Emulatoren hab ich eh gar keine Erfahrung, noch nutze ich sie ..warum auch? wenn man Original-Hardware hat?


    dann kommt eben weiterhin die 1351 zum Einsatz ... funzt ja seit eh und je...


    Vielen Dank cassy-de für die Erklärung - das spart mir langes rumprobieren :thumbup:

  • Hi, habe die jetzt auch mal aufgebaut.


    und es gefällt mir sogar besser als Orginal. :D :thumbup:

  • ..aber das sieht aus, wie der Startbildschirm vom Final Cartridge III ?

    ..muss man dafür nicht die Maus als "Joystick" -Maus nutzen? ...ich war ja grad noch bei Boulderdash64 und da war das auch so, dass er seine Maus extra "umschalten" musste, damit sie im FC3 funktioniert hat :/

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!