Hello, Guest the thread was 54 called and contains 2 replays

last post from Mad at the

CBM 8032-SK

  • Heute endlich werde ich den CBM 8032-SK vorstellen und die Reparatur oder Wiederbelebung dokumentieren .


    Vorweg ein paar Infos zum CBM 8032-SK


    Technische Daten zum 8032-SK

    • CPU: MOS 6502, 1 MHz
    • Ram: 32KB
    • Grafik: 80×25 Zeichen, Monochrome
    • Preis 1982: ca. 4514,35 DM

    Leider habe ich kein Prospekt zum CBM 8032-SK gefunden .


    hier ein paar Links mit Infos zum 8032-sk


    https://oldcrap.org/2022/05/10/commodore-pet-8032-sk/


    http://www.zimmers.net/cbmpics/c8032sk.html


    http://cbmmuseum.kuto.de/cbm_4000.html


    Pet Wiki : https://en.wikipedia.org/wiki/Commodore_PET



    Hier Bilder von meinem , überholten, CMB 8032-SK






    und jetzt werde ich noch mal kurz beschreiben was alles so defekt war und was repariert wurde .


    Das habe ich im VzEkC e.v. schon mal beschrieben, bzw. die entsprechendenTips und Tricks bekommen https://forum.classic-computin…chirm-bleibt-aber-dunkel/


    Nach dem Einschalten des CBM 8032-SK bleib auf jedenfall der Bildschirm dunkel, es meldetet sich aber der Begrüßungs-Piep .


    das war erst mal schon ein gutes Zeichen.


    Bevor ich den Rechner eingeschaltet habe wurde aber erst mal der CBM 8032-SK optisch untersucht ..


    Folgendes ist dabei entdeckt worden :


    Schmauchspuren auf der Platine, in der Nähe vom Stromanschluss




    und am Gehäuse in der Nähe vom Trafo



    Da ist wohl mal der Enstörkondensator explodiert . Aber das ist bei den alten Pets ja normal, wenn man die Geräte einschaltet ohne die Kondensatoren zu ersetzen oder einfach auszubauen .


    Auch die Platine sah sehr eingestaubt aus ..



    Nach der Reinigung



    habe ich alles wieder zusammengebaut un den Rechner ein erstes mal eingeschaltet.


    Wie oben geschrieben, Begrüßung Dudelt kommt der Bildschirm bleibt dunkel .


    - also erst mal Spannungen Messen .. alles soweit OK . +/- 5 V , 12 V und die ungeregelten 9 V sind vorhanden


    Da der Monitor den gleichen Anschluß wie mein 8296 hat habe ich den 8032-sk Monitor am 8296 Rechner getestet. Er war in Ordnung .. also weiter geht die Suche .


    Leider sind die meisten IC's auf der Platine eingelötet , so das man mit austauschen um so den Fehler zu finden nicht so schnell weiter kommt .


    Aber mit Hilfe der Jungs, besonders Christian @Toast_R haben wir letztendlich den CBM zum laufen gebracht .


    Der erste Tip :


    Mal ?chr$(7) eingeben .

    Wenn er dann klingelt, ist die Reset-Routine komplett bis 'ready.' durchgelaufen, und das Problem liegt wirklich nur in der Bilderzeugung.

    leider hat es nicht geklingelt, also weiter mit anderen Tests nachdem ich ausgeschlossen habe das es an der Tastatur oder Tastaturbelegung liegt .


    Ein PRINT chr$(7) bringt auch kein klingeln ..


    Danach wurden die Ram Bänke getauscht indem man R10 und R11 über kreuz verbindet ,


    Die Rambänke scheinen erst mal nicht nach Problem zu sein, es hat sich nichts geändert .


    Jetzt wird es etwas komplizierter und ich habe mit Hilfe eines Oszi's und einem logic Tester weitere Test's unternommen :


    Dazu habe ich erst mal einen 6502 NOP-Tester gebastelt . Wir so auch im ServiceManual beschrieben




    Quote from ServiceManual CBM 4032/8032

    Den No-Operation-Tester - kurz NOP-Tester genannt - benötigt man um Kurzschlüsse oder Unterbrechungen auf dem Adressbus

    festzustellen.

    Um den NOP-Tester herzustellen, wird ein HP 6502 oder uP 6501 modifiziert. Der NOP-Tester kann überall dort angewandt werden, wo ein 6502 oder 6504 im Einsatz ist.


    Dann habe ich , weil ich mit dem Oszi nicht so fit bin, mit dem Logitester ( von Helmut @axorp ) der CBM 8032 durchsucht .


    Das ist der Logitester




    und hier ein Video wie er arbeitet :


    Axorp‘s 4040 Logiktester an einem CBM 8296 CharRom Pin 18



    Folgende Pins habe ich mit dem Tester getestet :


    Schaltplan Bezeichnung Seite Chip Pos. Pin Signal Bemerkung
    CPU und Memory Expansion 1/11 6502 UB14 8-25 A0-A19 Signale werden hochgezählt , ab Pin 14/15 wird langsamer gezählt
    CPU und Memory Expansion 1/11 74LS244 UD13

    UD14
    1,3,5,

    7-9,

    12,13,14

    16,17,18
    BA0 - BA15 Signale auf allen Pins werden hochgezählt
    IEEE488- Interface 2/11 6520 UB16 22-24 CS0,CS1,C2 Signale auf allen Pins werden hochgezählt
    Cassette + Keyboard 3/11 6522 UB15 23,24 CS1,CS2 Signale auf allen Pins werden hochgezählt
    Cassette + Keyboard 3/11 6520 UB12 22-24
    CS0,CS1,C2 Signale auf allen Pins werden hochgezählt
    ROMS 4/11 UD6 - UD12 20 CS Signale auf allen Pins werden hochgezählt

    auch an den beiden leeren Plätzen UD11 und UD12
    ROMS 4/11 UD6 - UD12

    1-9

    18,19,22,23
    A0-A6 Signale auf allen Pins werden hochgezählt

    auch an den beiden leeren Plätzen UD11 und UD12
    Main Ram 5/11 4114 UA4-UA19

    15 CAS Signale auf allen Pins werden hochgezählt
    Main Ram 5/11 4114 UA4-UA19

    5-7,

    10-13
    A0-A6 Signale auf allen Pins werden hochgezählt
    Master timing 6/11 74LS164 UE3 9 CL kein Signal
    Display Adress MUX 7/11 74LS157 UC8-UC10 4,7,9,12 SA0-SA9 Signale auf allen Pins werden hochgezählt
    Dot Gen + Display Rams 8/11 CharRom UA3 18,20 CS2,CS1 Signale auf allen Pins werden hochgezählt
    Dot Gen + Display Rams 8/11 2114 UC4,UC5 1-7,

    15-17
    A0-A9 Signale auf allen Pins werden hochgezählt
    Odd Display Rams 9/11 2114 UC6,UC7 1-7,

    15-17
    A0-A9 Signale auf allen Pins werden hochgezählt
    CRTC and SYNC Buffers 10/11 6545 UB13 25 CS Signal ist bei eingesetzen NOP Adapter da .

    Ohne NOP Adapter wird hier kein Signal hochgezählt


    Dann wurden die Kernel Roms vermutet .


    Um die auszulesen, benutzt man freie Steckplätze in einem funktionierenden CBM .


    das wird dann so gemacht :


    Letztendlich waren es die Roms aber auch nicht , so das ich weiter gesucht habe ...


    Da ich die Test's mit dem Logitester gemacht habe hat man leider noch eine kleine Fehlerquelle , denn der Logitester prüft nicht auf korrekte LogicPegel die zwischen LOW 0,8V und High Pegel über 2,4V liegen müssen .


    Das geht nur mit dem Oszi .


    hier mal die Signale auf der BA7 Leitung



    hier die Signale auf der x8xx Leitung



    Hier sieht man nun das die Pegel der BA7 Leitung nicht unter low 1,74 V geht.


    jetzt wurden die I/O Chips 6522 und 6522 vermutet .


    Da die nicht gezockelt sind mussten die erst mal raus ..

    Das geht bei den alten CBM Boards eigentlich recht einfach, ich war überrascht .




    Die Chips wurden in dem 4032, den ich parallel reanimiert hatte , getestet und funktionieren dort .


    Da nun schon fast alle großen Chips getauscht bzw. getestet wurden habe ich dann auch noch den CRTC ausgelötet .

    Ein Test im 4032 ergab das der Rechner nicht mehr läuft . Da freut man sich , denn ich hatte noch einen anderen CRTC aus einem Ersatzboard und könnt mit dem den CBM 8032-SK doch noch zum funktionieren überreden .


    Ich hoffe ich habe ich nicht zu sehr gelangweilt , ich wollte nur mal den Weg aufzeigen wie wir den Rechner wieder zum Leben erweckt haben .


    Die ganze Aktion hat insgesamt 6 Tage gedauert ....


    dann werde ich demnächst die Wiederbelebung des CBM 4032 beschreiben ...

    Eine ADMIN schläft nicht er ROOT

  • Danke Andreas,


    na ja, die CBM Kisten haben ja auch nur einen 8-Bit Bus :D Ist ja ähnlich ..



    Der Logictester ist witzig, habe ihn glaube whodan abgekauft und bei dieser Reparatur das erst mal benutz :whistling:


    Es funktioniert als Unterstützung, man muss trotzdem die Pegel mit dem Oszi nachkontrollieren .

    Eine ADMIN schläft nicht er ROOT

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!